Instalacja, backup, konfiguracja

Re: Instalacja, backup, konfiguracja

Postautor: lukebe » 13 kwie 2011 12:47

Ja tez tak miałem - bywało różnie, czasem były problemy przy wyłączaniu. Od kiedy zainstalowałem JBossa jako usługę - wszystko gra i jest bezobsługowe :)
lukebe
Omnibus
Omnibus

Re: Instalacja, backup, konfiguracja

Postautor: Łukasz W » 13 kwie 2011 12:52

lukebe pisze:Ja tez tak miałem - bywało różnie, czasem były problemy przy wyłączaniu. Od kiedy zainstalowałem JBossa jako usługę - wszystko gra i jest bezobsługowe :)


Reasumując FB jako usługa, JBoss jako aplikacja :) czas spróbować
Łukasz W
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: TheSaint » 13 kwie 2011 14:53

a napisz co i jak instalowałeś?
TheSaint
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: Łukasz W » 13 kwie 2011 14:59

Java up. 14, FB 2.1.3 jako usługa, Pomost STD 1-1.0 (tylko taka widnieje na ftp) jako usługa w roli serwer/wersja jednostanowiskowa. Teraz chce spróbować instalować jako aplikacja. Następnie o ile dobrze myślę to wystarczy instalka na końcówkach jako klient i powinno działać w sieci. Chce także aby na kompie na którym mam "serwer" działał pomost (coś typu niepełny serwer w progressowym pomoście) ale z tym kłopotu nie powinno być chyba.

Edit: Instalacja jako aplikacja ładnie zadziała tylko dlaczego cały czas okno dosowe jest widoczne, nie działa w tle. Podczas próby wyjścia serwer się zatrzymuje
Łukasz W
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: jack » 14 kwie 2011 14:02

Instalację jako usługę omówiłem na pierwszej stronie tego wątku. Jeżeli masz serwer 64-bit to przeczytaj, jeżeli 32-bit to sprawdzć czy usługa JBossPomost napewno istnieje i czy jest uruchomiona.

PS
Podobna miał być już Pomost Std. z poprawionym instalatorem, ale jakoś na FTP go nie widać.
jack
Profesor
Profesor

Re: Instalacja, backup, konfiguracja

Postautor: lukebe » 14 kwie 2011 14:08

Łukasz W pisze: JBoss jako aplikacja


Też jako usługa :)
lukebe
Omnibus
Omnibus

Re: Instalacja, backup, konfiguracja

Postautor: TheSaint » 14 kwie 2011 14:57

Łukasz W pisze:Instalacja jako aplikacja ładnie zadziała tylko dlaczego cały czas okno dosowe jest widoczne, nie działa w tle. Podczas próby wyjścia serwer się zatrzymuje
no bo tak jest jak działa jako aplikacja.
TheSaint
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: Łukasz W » 14 kwie 2011 21:47

jack pisze:jeżeli 32-bit to sprawdzć czy usługa JBossPomost napewno istnieje i czy jest uruchomiona.


Usługa jest, ale nie da się uruchomić (może to mieć związek z tym, że zbytni chciałem przekombinować). Mam jeszcze dwa dni więc jak to się mówi "mamy jeszcze czas" na dopracowanie ;]
Łukasz W
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: TheSaint » 15 kwie 2011 7:46

a jako aplikacja masz ustawione na automatyczne uruchamianie?
TheSaint
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: jack » 15 kwie 2011 8:43

Łukasz W pisze:
jack pisze:jeżeli 32-bit to sprawdzć czy usługa JBossPomost napewno istnieje i czy jest uruchomiona.


Usługa jest, ale nie da się uruchomić (może to mieć związek z tym, że zbytni chciałem przekombinować). Mam jeszcze dwa dni więc jak to się mówi "mamy jeszcze czas" na dopracowanie ;]
Bo pewnie zainstalowała się usługa 32-bity a system prawdopodobnie masz x64 (mogę się tylko domyślać bo niesety nadal nie napisałeś jaki, a od tego należało zacząć). Jeżeli tak to należy usunąć tę usługę i zainstalować tak jak napisałem w pierwszym poście tego wątku:
Należy przekopiować skrypty instalacyjne usługi z foldera JBoss\service do JBoss\service64 i stamtąd uruchomić lub samemu zarejestrować usługę za pomocą polecenia sc.

Ponadto odpalając skrypt ręcznie warto to zrobić za pomocą "uruchom jako administrator" lub jak kto woli wyłączyć UAC.
jack
Profesor
Profesor

Re: Instalacja, backup, konfiguracja

Postautor: Łukasz W » 15 kwie 2011 11:05

jack mam 32 bitowy i już po kłopocie :) Przekombinowałem i instalowałem raz jedno raz drugie że była aplikacja i usługa. Wystarczy wywalić z autostartu aplikację i działa jako usługa.
Łukasz W
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: pluti » 22 kwie 2011 9:32

ja się migrowałem w poniedziałek i przy instalacji jako usługa jboss nie wstawał Win2k3 rzucał komunikatem błędu, że coś jest bezczynna już nie pamiętam dokładnie,
więc mam zainstalowany jako aplikacja i okno dosowe wisi ... a raczej wisiało bo zrobiłem shedula który uruchamia się przy starcie systemu i uruchamia jtc-run.bat i okienko dosowe jest niewidoczne
pluti
AS
AS

Re: Instalacja, backup, konfiguracja

Postautor: pluti » 22 kwie 2011 9:34

a czy FBM który robi backup robi to dla obu baz (migracja i pomost)?
pytam bo plik wynikowy jest bardzo mały
pluti
AS
AS

Re: Instalacja, backup, konfiguracja

Postautor: Łukasz W » 06 maja 2011 15:27

Podczas próby wykonania kopii programem FBManager wywala mi taki błąd. Chodzi o samo hasło do bazy??
Łukasz W
GURU
GURU

Re: Instalacja, backup, konfiguracja

Postautor: KingDiamond » 13 cze 2011 10:01

musisz odpalić fbconfiga z katalogu jbossa, sprawdź i powiedz czy pomogło ;)
KingDiamond
Konsultant
Konsultant

PoprzedniaNastępna

Wróć do Administracja systemem

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 2 gości