Sepi, Firefox, wersja Java na końcówce, pomost_std

Platforma łącząca Rynek Pracy i Pomocy Społecznej

Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: tlewandowski » 15 lis 2012 14:55

Do poprawnego funkcjonowania SEPI na stacjach roboczych powinna być zainstalowana Java w wersji 1.6.0_u24 lub wyższa.
Nie jest prawdą że do poprawnej pracy (podpis zaświadczeń) w Sepi jest wymagana tylko i wyłącznie najnowsza Java w wersji 1.7.x
Wraz z instalacją Javy na stacji roboczej w przeglądarce Firefox widzimy dostępny plugin o nazwie: JAVA (TM) Platform <numer_wersji>.

Pojawiający się komunikat w SEPI o tym, że "Twoja przeglądarka nie obsługuje Javy ..." (załącznik 1.png) ma swoje źródło w tym, że od pewnej wersji (prawdopodobnie 15) Firefox stosuje politykę sprawdzania wersji i ewentualnego blokowania pluginu Javy jeśli ten jest w innej wersji niż aktualnie najnowsza.

Aby pracować zatem na niższych wersjach Javy należy w przeglądarce w Dodatkach ręcznie aktywować plugin. Firefox->Narzędzia->Dodatki-> Java (TM) .. ->Włącz (załącznik 2.png). Proszę zaznajomionych z tematem o przekazanie namiaru na ten post do Ośrodków pomocy społecznej, które aby pracować w Pomost_std potrzebują maksymalnie Javy w wersji 1.6
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego postu.
tlewandowski
Nowicjusz
Nowicjusz

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: gmopsbolkow » 28 lis 2013 16:38

Niestety w najnowszym Firefox to jest 25.0.1 nie da się włączyć dodatku java jeśli jest nie aktualny (a z wiadomych względów pomosty STD nie mogę uaktualnić javy) może ma ktoś jakiś pomysł jak to rozwiązać

U mnie w Firefox wygląda to tak

Musisz się zalogować żeby zobaczyć link!

a opcje do tych dodatków tylko takie:

Musisz się zalogować żeby zobaczyć link!
gmopsbolkow
Nowicjusz
Nowicjusz

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: TheSaint » 29 lis 2013 9:48

ja mam dodatek 6 u 30 - i tam jest wybór "zawsze aktywuj" - SEPI działa bezproblemowo
TheSaint
GURU
GURU

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: PawełR » 29 lis 2013 10:49

tak przy okazji Java jest wymagana tylko w przypadku gdy będziemy podpisywać elektronicznie? W przypadku gdy nie mamy a tylko odbieramy podpisane Java jest nie istotna?
PawełR
GWIAZDA
GWIAZDA

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: Łukasz W » 29 lis 2013 11:03

Java jest potrzebna gdyż całą komunikacja na tym polega.
Łukasz W
GURU
GURU

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: karson » 29 lis 2013 11:20

potrzbna - bo do obsługi podpisu sa servlety/aplety w javie napisane
karson
Omnibus
Omnibus

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: gmopsbolkow » 29 lis 2013 13:07

u mnie z java 7 u15 nie ma takiej opcji zawsze aktywuj (tak jak widoczne na screenach)
gmopsbolkow
Nowicjusz
Nowicjusz

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: TheSaint » 29 lis 2013 13:07

no to ustaw pytaj o aktywację - co najwyżej za każdym razem będziesz musiał kliknąć
TheSaint
GURU
GURU

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: Łukasz W » 29 lis 2013 13:10

W którejś wersji było to właśnie skopane
Łukasz W
GURU
GURU

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: PawełR » 29 lis 2013 13:50

Java jest potrzebna gdyż całą komunikacja na tym polega.
chodzi mi o stanowisko nie o serwer do wysyłki. Czy stanowisko też potrzebuje Javy?
potrzbna - bo do obsługi podpisu sa servlety/aplety w javie napisane
pytałem o przypadek bez podpisu elektronicznego z naszej strony
pytam o to bo u nie w chromie wtyczka jest zablokowana z powodu nieaktualności i mogę ją mimo to uruchomić ale nie robiąc tego mogę chodzić po aplikacji i wszystko mi się ładnie otwiera. Sprawdzania danych nie próbowałem bez uruchamiania dlatego pytam o tą kwestię (bo na razie chwilowo nie mam potrzeby sprawdzania)
Właśnie sprawdziłem że wyszukiwanie raportowe działa mimo zablokowania wtyczki Java (czyli SEPI w trybie saas nie wymaga po stronie użytkownika aktywnej Javy w przypadku gdy nie korzystamy z podpisu)
PawełR
GWIAZDA
GWIAZDA

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: Łukasz W » 29 lis 2013 14:02

PawełR pisze:chodzi mi o stanowisko nie o serwer do wysyłki.


A jak działają Ci przełączniki i cała wyszukiwarka SEPI?? Nie chodziło mi o komunikację jako zasilenie a połączenie SEPI<->klient
Łukasz W
GURU
GURU

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: PawełR » 29 lis 2013 14:04

A jak działają Ci przełączniki i cała wyszukiwarka SEPI?? Nie chodziło mi o komunikację jako zasilenie a połączenie SEPI<->klient
wszystko działa jak należy i nawet przed chwilą drukowałem raport. W wyżej wciąć wisi okno z możliwością aktualizacji JAvy albo " uruchomieniem tym razem" Więc jak dla mnie to Java jest potrzebna tylko do uruchomienia aplikacji czytającej kartę z podpisem.
PawełR
GWIAZDA
GWIAZDA

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: Łukasz W » 29 lis 2013 14:07

PawełR pisze:W wyżej wciąć wisi okno z możliwością aktualizacji JAvy albo " uruchomieniem tym razem"


Ale środowisko JAVY zainstalowane :)
Łukasz W
GURU
GURU

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: PawełR » 29 lis 2013 14:08

Ale środowisko JAVY zainstalowane
zainstalowane bo tu mam pomost ale w przeglądarce wtyczka Java zablokowana a właśnie o nią mi chodzi.
Mam w SEPI komunikat
Wtyczka JAVA (TM) PLATFORM została wyłączona.
Do poprawnego złożenia podpisu elektronicznego wymagane jest środowisko Java w wersji 1.6.0u24 lub wyższe
więc tak jak wyżej pisałem do podpisu musi być
Sugerujesz że byłaby jakaś różnica gdybym pozbył się całego środowiska Javy i Chrome nie miało by co blokować bo by nie było Javy i wtedy SEPI by nie działało tak jak działa na JAvie która jest zablokowana? :idea:
PawełR
GWIAZDA
GWIAZDA

Re: Sepi, Firefox, wersja Java na końcówce, pomost_std

Postautor: Łukasz W » 29 lis 2013 14:12

Po wyczyszczeniu cache nawet aplet w IE się aktualizują.
Łukasz W
GURU
GURU

Następna

Wróć do SEPI

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość